Troubleshooting Salesforce Sync Failure

Sync Failed with Error - HTTP Error Response: 401 Unauthorized with error response [{"message":"Session expired or invalid","errorCode":"INVALID_SESSION_ID"}]

https://developer.salesforce.com/forums/?id=906F000000099xAIAQ https://developer.salesforce.com/forums?id=906F000000099x7IAA

Root Cause:

Salesforce Lightning Domain in the Zilla application instance config is not set to the current domain from Settings -> Setup -> Company Settings -> My Domain -> My Domain Settings -> Current My Domain URL.

Solution:

Need to connect with customer and set the Salesforce Lightning Domain in the Zilla application instance config from Settings -> Setup -> Company Settings -> My Domain -> My Domain Settings -> Current My Domain URL. Please refer to .